Tải bản đầy đủ - 0 (trang)
CHƯƠNG 3: MÔ HÌNH ÁP DỤNG

CHƯƠNG 3: MÔ HÌNH ÁP DỤNG

Tải bản đầy đủ - 0trang

23



- Nhược điểm:

+ Khơng có khả năng tự động cập nhật đường đi.

+ Phải cấu hình thủ cơng khi mạng có sự thay đổi.

+ Phù hợp với mạng nhỏ, rất khó triển khai trên mạng lớn.

- Một số tình huống bắt buộc dùng định tuyến tĩnh:

+ Đường truyền có băng thơng thấp

+ Người quản trị mạng cần kiểm sốt các kết nối.

+ Kết nối dùng định tuyến tĩnh là đường dự phòng cho đường kết nối dùng giao thức định

tuyến động.

+ Chỉ có một đường duy nhất đi ra mạng bên ngồi (mạng stub).

+ Router có ít tài ngun và không thể chạy một giao thức định tuyến động.

+ Người quản trị mạng cần kiểm soát bảng định tuyến và cho phép các giao thức classful

và classless.



3.1.2 Cấu hình định tuyến tĩnh:



Sơ đồ ví dụ



24



Hình trên là hai router, R1 sử dụng cổng f0/0 đấu xuống mạng LAN có subnet

192.168.1.0/24. Tương tự, R2 sử dụng cổng f0/0 đấu xuống PC có subnet 192.168.2.0/24.

Subnet sử dụng cho kết nối leased-line nối giữa hai router là 192.168.3.0/24. Đầu tiên,

chúng ta phải cấu hình đặt địa chỉ IP cho các cổng của router, cũng như IP và Defaultgateway cho các PC. Default-gateway hiểu đơn giản là IP của cổng của router gần nhất

mà PC đó kết nối trực tiếp đến.

Cấu hình định tuyến tĩnh trên router Cisco được thực hiện bằng cách sử dụng lệnh có cú

pháp như sau:

Router(config) # ip route destination_subnet subnetmask{IP_next_hop|output_interface}

[AD]

Trong đó:

destination_subnet: mạng đích đến.

subnetmask: subnet – mask của mạng đích.

IP_next_hop: địa chỉ IP của trạm kế tiếp trên đường đi.

output_interface: cổng ra trên router.

AD: chỉ số AD của route khai báo, sử dụng trong trường hợp có cấu hình dự phòng.

Trong ví dụ hình trên, từ R1 muốn đi đến mạng 192.168.2.0/24 thì phải đi ra khỏi cổng

f1/0. Để thể hiện điều đó vào bảng định tuyến phải thực hiện cấu hình:

R1 (config) # ip route 192.168.2.0 255.255.255.0 f1/0

hoặc

R1 (config) # ip route 192.168.2.0 255.255.255.0 192.168.3.2

R2 muốn đi đến mạng 192.168.1.0/24 thì phải đi ra khỏi cổng f1/0:

R2 (config) # ip route 192.168.1.0 255.255.255.0 f1/0

hoặc

R2 (config) # ip route 192.168.1.0 255.255.255.0 192.168.3.1

Sau khi đã cấu hình xong các route cho các mạng 192.168.1.0/24 và 192.168.2.0/24,

kiểm tra bảng định tuyến trên mỗi router: Bảng định tuyến của R1:



25



R1#show ip route

C 192.168.1.0/24 is directly connected, FastEthernet0/0

S 192.168.2.0/24 [1/0] via 192.168.3.2

C 192.168.3.0/24 is directly connected, FastEthernet1/0

Bảng định tuyến của R2:

R2#show ip route

S 192.168.1.0/24 [1/0] via 192.168.3.1

C 192.168.2.0/24 is directly connected, FastEthernet0/0

C 192.168.3.0/24 is directly connected, FastEthernet1/0

Kí tự “S” ở đầu dòng thể hiện rằng các thông tin định tuyến này được học vào bảng định

tuyến thông qua định tuyến tĩnh và các dòng mơ tả các mạng kết nối trực tiếp được ký

hiệu bởi kí tự “C” – connected – kết nối trực tiếp.



26



3.1.3 Default route:

Được dùng để định tuyến mặc định tất cả dữ liệu đến một mạng bất kỳ đi theo đường nào

đó. Nhưng nếu mạng đó đã có đường đi trong bảng định tuyến, thì gói tin sẽ ưu tiên đi

theo đường đi rõ ràng trước.

Router (config) # ip route 0.0.0.0 0.0.0.0 {ip next-hop | exit interface}



3.2 Mơ hình định tuyến động :



Các router sẽ trao đổi thông tin định tuyến với nhau. Từ thông tin nhận được, mỗi router

sẽ thực hiện tính tốn định tuyến từ đó xây dựng bảng định tuyến gồm các đường đi tối

ưu nhất đến mọi điểm trong hệ thống mạng. Với định tuyến động, các router phải chạy

các giao thức định tuyến (routing protocol). Giao thức định tuyến động không chỉ thực

hiện chức năng tự tìm đường và cập nhật bảng định tuyến, nó còn có thể xác định tuyến

đường đi tốt nhất thay thế khi tuyến đường đi tốt nhất không thể sử dụng được. Khả năng

thích ứng nhanh với sự thay đổi mạng là lợi thế rõ rệt nhất của giao thức định tuyến động

so với giao thức định tuyến tĩnh.

- Ưu điểm:

+ Đơn giản trong việc cấu hình.



27



+ Tự động tìm ra những tuyến đường thay thế khi mạng thay đổi.

- Nhược điểm:

+ Yêu cầu xử lí của CPU của router cao hơn so với định tuyến tĩnh.

+ Tiêu tốn một phần băng thông trên mạng để xây dựng bảng định tuyến.

Tất cả các giao thức định tuyến động được xây dựng dựa trên giải thuật. Định tuyến động

chia thành hai trường phái: các giao thức định tuyến ngoài - Exterior Gateway Protocol

(EGP) và các giao thức định tuyến trong - Interior Gateway Protocol (IGP).

- Các giao thức định tuyến ngoài (EGP) với giao thức tiêu biểu: BGP (Border Gateway

Protocol) là loại giao thức được dùng để chạy giữa các router thuộc các AS khác nhau,

phục vụ cho việc trao đổi thông tin định tuyến giữa các AS. AS - Autonomous System tạm dịch là Hệ tự trị là tập hợp các router chung một chính sách về định tuyến.

- Các giao thức định tuyến trong (IGP) gồm các giao thức tiêu biểu như: RIP, OSPF,

EIGRP. Trong đó, RIP và OSPF là các giao thức chuẩn quốc tế, EIGRP là giao thức của

Cisco, chỉ chạy trên thiết bị Cisco. IGP là loại giao thức định tuyến chạy giữa các router

nằm bên trong một AS.



3.2.1 Rip v2:

3.2.1.1 Giới thiệu:

RIP (Routing Information Protocol) là một giao thức định tuyến dùng để quảng bá thơng

tin về địa chỉ mà mình muốn quảng bá ra bên ngồi và thu thập thơng tin để hình thành

bảng định tuyến (Routing Table) cho Router. Đây là loại giao thức Distance Vector sử

dụng tiêu chí chọn đường chủ yếu là dựa vào số hop (hop count) và các địa chỉ mà Rip

muốn quảng bá được gửi đi ở dạng Classful (đối với RIP verion 1) và Classless (đối với

RIP version 2).

Vì sử dụng tiêu chí định tuyến là hop count và bị giới hạn ở số hop là 15 nên giao thức

này chỉ được sử dụng trong các mạng nhỏ (dưới 15 hop)



3.2.1.2 Sơ đồ bài Lab:



28



3.2.1.3 Mục tiêu:

-Trước khi cấu hình định tuyến bằng RIPv2 cho 2 router chúng ta sẽ thấy ngồi từ PC1

không thể ping được đến router TGM2 vì lý do Router TGM2 thơng tin về mạng

10.0.0.0/24 ( LAN1) nằm đâu.

- Sau khi cấu hình RIPv2 thì PC1 phải ping được đến TGM2.



3.2.1.4 Các bước tiến hành:

- Trước tiên bạn cấu hình cho các thiết bị như sau:

Router TGM1

Router>enable

Router#configure terminal

Router(config)#hostname TGM1

TGM1(config)#interface Se0/3

TGM1(config-if)#ip address 220.245.24.21 255.255.255.252

TGM1(config-if)#no shutdown

TGM1(config-if)#exit



Router TGM2

Router>enable

Router#configure terminal



29



Router(config)#hostname TGM2

TGM2(config)#interface e0/0

TGM2(config-if)#ip address 220.245.24.22 255.255.255.0

TGM2(config-if)#no shutdown

TGM2(config-if)#exit

TGM2(config)#interfacae e0/1

TGM2(config-if)#ip address 192.168.0.2 255.255.255.0

TGM2(config-if)#no shutdown

TGM2(config-if)#exit

PC1:

IP:192.168.10.2

Subnetmask:255.255.255.0

Gateway: 192.168.10.1

PC2:

IP:192.168.0.2

Subnetmask:255.255.255.0

Gateway: 192.168.0.1

- Bạn thực hiện việc kiểm tra các kết nối bằng lệnh Ping



Ping từ PC1 sang địa chỉ 220.245.24.22

Ping từ PC1 sang địa chỉ 192.168.1.1

Ping từ PC1 sang địa chỉ 192.168.1.2

- Đối với PC1 bạn không thể Ping thấy địa chỉ 192.168.1.2

Bạn thực hiện việc kiểm tra tương tự ở PC2



Ping địa chỉ 220.245.24.22

Ping địa chỉ 192.168.1.2



30



Ping địa chỉ 192.168.1.1

- Thực hiện các lệnh Ping từ Router TGM1:

TGM1#ping192.168.1.2



- Thực hiện các lệnh Ping từ Router TGM2

TGM2#ping 192.168.1.1



TGM2#ping 192.168.10.2



- Bạn xem bảng thông tin định tuyến của từng Router



31



TGM1#show ip route



32



TGM2#show ip route



Nhận xét : Bạn thấy rằng thông tin địa chỉ của các mạng mà bạn thực hiện lệnh Ping

không thành công không được lưu trên bảng định tuyến.

-Bạn thực hiện việc cấu hình RIP cho các Router Cisco như sau:

TGM1(config)#router

TGM1(config-router)#network

TGM1(config-router)#network

TGM1(config-router)#exit

TGM2(config)#router

TGM2(config-router)#network

TGM2(config-router)#network

TGM2(config-router)#exit

- Bạn xem lại bảng thông tin định tuyến:



rip

192.168.1.0

192.168.0.1

rip

192.168.10.1

192.168.1.0



33



TGM1#show ip route



TGM2#show ip route



Tài liệu bạn tìm kiếm đã sẵn sàng tải về

CHƯƠNG 3: MÔ HÌNH ÁP DỤNG

Tải bản đầy đủ ngay(0 tr)

×