Tải bản đầy đủ - 0 (trang)
CHƯƠNG 3: ỨNG DỤNG CÔNG NGHỆ IP MULTICAST TRONG MPLS VPN (MPVN)

CHƯƠNG 3: ỨNG DỤNG CÔNG NGHỆ IP MULTICAST TRONG MPLS VPN (MPVN)

Tải bản đầy đủ - 0trang

Đồ án tốt nghiệp đại học

3.2. Các thành phần và cách thức hoạt động của MVPN

Định tuyến và chuyển tiếp multicast VPN và miền multicast

MVPN truyền thông tin định tuyến multicast dựa trên bảng định tuyến và chuyển

tiếp VPN. Khi bộ định tuyến biên của nhà cung cấp dịch vụ (PE) nhận dữ liệu multicast

hoặc các gói tin điều khiển từ bộ định tuyến biên của khách hàng (CE), việc chuyển tiếp

được thực hiện dựa trên các thông tin chứa trong tiến trình định tuyến và chuyển tiếp

multicast VPN (MVRF). MVPN khơng sử dụng chuyển đổi nhãn.



Hình 3.1. Tiến trình định tuyến và chuyển tiếp multicast VPN

Một tập hợp các MVRF có thể gửi lưu lượng multicast với nhau tạo thành một

miền multicast. Ví dụ: Miền multicast dành cho một doanh nghiệp muốn gửi một số loại

lưu lượng truy cập đa hướng cho các site bao gồm tất cả các bộ định tuyến CE liên kết

với doanh nghiệp đó.

Cây phân phối multicast (Multicast Distribution Trees - MDT)

MVPN thiết lập mặc định một tạo cây phân phối multicast (MDT) tĩnh cho mỗi

miền multicast. MDT mặc định định nghĩa cho đường dẫn được sử dụng bởi các bộ định

tuyến PE để gửi dữ liệu multicast và điều khiển các thông báo đến mọi bộ định tuyến

PE khác trong miền multicast.

Nếu Source Specific Multicast (SSM) được sử dụng làm giao thức định tuyến

multicast cốt lõi, thì các địa chỉ IP multicast được sử dụng cho cây phân phối dữ liệu



Đậu Văn Thắng – D13VT6



64



Đồ án tốt nghiệp đại học

multicast (MDT) phải được cấu hình trong phạm vi SSM trên tất cả các bộ định tuyến

PE.

MVPN cũng hỗ trợ việc tạo cây phân phối multicast tự động cho việc truyền băng

thông rộng. Dữ liệu MDT (Data-MDT) là một cây multicast được xây dựng theo yêu

cầu. Các điều kiện để tạo Data-MDT phụ thuộc vào ngưỡng lưu lượng truy cập (1Kbps

theo mặc định) và hoặc danh sách truy cập xác định địa chỉ nguồn cụ thể bên trong VPN.

Khi ngưỡng lưu lượng truy cập vượt quá tỷ lệ được định cấu hình, bộ định tuyến PE gửi

một thông điệp Data-Join đến RP với địa chỉ nhóm. Nó tạo ra mục nhập (S, G) ví dụ

(1.1.1.1, 239.192.20.0) trong bảng định tuyến multicast tồn cầu của nó bằng cách chọn

một địa chỉ nhóm từ dải và bắt đầu gửi lưu lượng truy cập đến nhóm Data-MDT. DataMDT chỉ được tạo ra bởi PE có nguồn được kết nối với site của nó. Data MDT được tạo

chỉ dành cho các tuyến đường đa hướng (S, G) trong bảng định tuyến VRF multicast.

Chúng không được tạo (*, G) cho bất kể nguồn dữ liệu riêng lẻ nào.

Giao diện đường hầm đa điểm (Multicast Tunnel Interface -MTI)

Khi MDT được tạo trên các bộ định tuyến PE, chúng ngay lập tức tạo giao diện

đường hầm multicast (MTI). Thông tin cập nhật MP-BGP được gửi đến tất cả các bộ

định tuyến PE là các bộ định tuyến ngang hàng với để chỉ ra sự có mặt của MDT. Bộ

định tuyến PE gửi ra một thơng báo tham gia vào nhóm multicast của Default-MDT.

Lưu lượng dữ liệu được truyền qua giao diện đường hầm được đóng gói bởi GRE

với địa chỉ đích là địa chỉ của nhóm multicast dành cho Default-MDT và địa chỉ nguồn

là địa chỉ định danh của bộ định tuyến liên kết với nguồn khởi tạo phiên. Quá trình này

sẽ được xảy ra cho tất cả các bộ định tuyến PE. Kết quả, Một giao diện đường hầm được

tạo ra để tương ứng cho mỗi MVRF.

Thông điệp cập nhật MDT cho MP-BGP

Khi một bộ định tuyến PE tạo ra một Default-MDT, nó cập nhật tới tất cả các kết

nối ngang hàng của nó bằng cách sử dụng MP-BGP. BGP sử dụng thuộc tính Extended

Community để quảng bá các thơng điệp cập nhật. Thông điệp cập nhật chứa các thông

tin sau đây:

(a) Thuộc tính MDT extended community cho nhóm Default-MDT có dạng số định

danh hệ thống tự tri (ASN): Địa chỉ nhóm Default-MDT

(b) MP_REACH_NLRI chứa địa chỉ kiểu VPNv4 với RD:ASN:Assigned-Number

cho biết RD này là một phần của địa chỉ nhóm MDT.



Đậu Văn Thắng – D13VT6



65



Đồ án tốt nghiệp đại học

Thiết lập quan hệ PIM

Một bộ định tuyến PE có thể có ba loại quan hệ hàng xóm PIM khác nhan:

(1) Giữa PE và CE: Quan hệ PIM của VRF được hình thành giữa các PE và các bộ

định tuyến CE cho mỗi một VRF. Cả hai PE và CE chạy cùng một chế độ PIM.

(2) Giữa PE và P: Sự liên kết PIM trên mạng lõi được hình thành giữa bộ định

tuyến PE và P thông qua giạo diện kết nối trực tiếp.

(3) Giữa PE và PE: Quan hệ PIM của VRF được hình thành giữa PE và các bộ định

tuyến PE từ xa thông qua giao diện đường hầm MTI cho một VRF cụ thể.

Mơ tả hoạt động

Trong ví dụ sau, một nhà cung cấp dịch vụ có một khách hàng multicast có văn

phòng ở Hà Nội, Sài Gòn và Đà Nẵng. Một quá trình multicast một chiều diễn ra ở Hà

Nội. Mạng lưới nhà cung cấp dịch vụ hỗ trợ cả ba site liên kết với khách hàng này, còn

site Nghệ An của một khách hàng doanh nghiệp khác.

Cây phân phối multicast mặc định (MDT default) cho khách hàng doanh nghiệp

bao gồm các bộ định tuyến nhà cung cấp dịch vụ P1, P2 và P3 và các bộ định tuyến PE

liên quan của chúng. PE4 không phải là một phần của cây phân phối multicast mặc định,

bởi vì nó được liên kết với một khách hàng khác. Hình 3.2 dưới đây minh họa cho thấy

khơng có dữ liệu nào đi dọc theo cây phân phối multicast mặc định, bởi vì khơng ai ở

bên ngồi site Hà Nội đã tham gia multicast.



Đậu Văn Thắng – D13VT6



66



Đồ án tốt nghiệp đại học

Hình 3.2. Topology cơ bản minh họa

Một máy tính ở site Sài Gòn tham gia phiên multicast. Bộ định tuyến PE liên kết

cùng site Sài Gòn gửi yêu cầu tham gia luồng thông qua MDT mặc định cho miền

multicast của khách hàng. PE1, bộ định tuyến PE liên kết với nguồn của phiên multicast,

nhận yêu cầu. Hình 3.3 minh hoạ rằng bộ định tuyến PE gửi yêu cầu đến bộ định tuyến

CE kết hợp với nguồn multicast (CE1a).



Hình 3.3. Khởi tạo Dữ liệu MDT

Bộ định tuyến CE (CE1a) bắt đầu gửi dữ liệu multicast đến bộ định tuyến PE

(PE1), nó sẽ gửi dữ liệu multicast dọc theo MDT mặc định. Ngay khi gửi dữ liệu

multicast, PE1 nhận ra rằng dữ liệu multicast vượt quá ngưỡng băng thông được quy

định trên một Data MDT. Do đó, PE1 tạo một MDT dữ liệu, gửi một thông báo đến tất

cả các bộ định tuyến sử dụng MDT mặc định có chứa thơng tin về MDT dữ liệu và, ba

giây sau, bắt đầu gửi dữ liệu multicast cho luồng cụ thể sử dụng MDT dữ liệu. Chỉ PE2

và PE4 có các máy thu quan tâm cho nguồn này, vì vậy chỉ có PE2 và PE4 mới tham

gia MDT dữ liệu và nhận được lưu lượng truy cập vào nó.

3.3. Mơ phỏng

Mục đích mơ phỏng

Mục đích của chương trình mơ phỏng:



Đậu Văn Thắng – D13VT6



67



Đồ án tốt nghiệp đại học

 Xây dựng miền MPLS Domain.

 Cấu hình MPLS VPN L3 ( sử dụng giao thức MP-BGP ) cho Customer.

 Cấu hình IP Multicast giữa các các site của Customer thông qua hạ tầng MPLS.

 So sánh, đánh giá hiệu năng khi sử dụng multicast so với unicast.

Mơ hình mơ phỏng

Để thực hiện được mục đích như trên đã đặt ra, ta đưa ra sơ đồ mơ hình mơ phỏng

như hình 3.4 sau đây:



Hình 3.4. Mơ hình mơ phỏng

Phân tích hệ thống

 OSPF domain và MPLS domain bao gồm :

 Loopback 1 và e0/1



của PE1 (R1)



 Loopback 2 và e0/2



của PE2 (R2)



 Loopback 3 và e0/3



của PE3 (R3)



 e0/1, e0/2 và e0/3



của P (R4)



 Range IP: Interface: 10.0.xy.0/24 ( x: Router X – y: Router Y, x < y)

 Loopback: x.x.x.x/32 ( x: Router X )

 BGP AS 123:



Đậu Văn Thắng – D13VT6



68



Đồ án tốt nghiệp đại học

 Loopback 1



của PE1 (R1)



 Loopback 2



của PE2 (R2)



 Loopback 3



của PE3 (R3)



 BGP AS 65000:

 Loopback 5



và e0/0



của CE-A1 (R5)



 Loopback 6



và e0/0



của CE-A2 (R6)



 Loopback 7



và e0/0



của CE-A3 (R7)



 Range IP: Interface: 192.168.xy.0/24 ( x: Router X – y: Router Y, x < y)

 Loopback: x.x.x.x/32 ( x: Router X )

 BGP AS 65000:

 Loopback 8 và e0/0



của CE-B1 (R8)



 Loopback 9 và e0/0



của CE-B2 (R9)



 Range IP: Interface: 192.168.xy.0/24 ( x: Router X – y: Router Y, x < y)

 Loopback: x.x.x.x/32 ( x: Router X )

 Peer neighbor BGP:

Local



Interface



IP



Neighbor



Interface



IP



Loopback 1



1.1.1.1/32



PE2



Loopback 2



2.2.2.2/32



PE3



Loopback 3



3.3.3.3/32



PE1



PE2



PE3



e0/0



192.168.15.1/24



CE-B1



e0/0



192.168.15.5/24



e1/0



192.168.18.1/24



CE-B1



e1/0



192.168.18.8/24



Loopback 2



2.2.2.2/32



PE1



Loopback 1



1.1.1.1/32



e0/0



192.168.26.2/24



CE-A2



e0/0



192.168.26.6/24



e1/0



192.168.29.2/24



CE-B2



e1/0



192.168.29.9/24



Loopback 3



3.3.3.3/32



PE1



Loopback 1



1.1.1.1/32



e0/0



192.168.37.3/24



CE-A3



e0/0



192.168.37.7/24



Đậu Văn Thắng – D13VT6



69



Đồ án tốt nghiệp đại học

 Cần phải tạo ra 2 VPN-L3 dùng giao thức MP-BGP qua miền MPLS để kết nối

2 nhóm khách hàng A và B

 VPN-L3 kết nối CE-A1 (R5), CE-A2 (R6) và CE-A3 (R7)

 VPN-L3 102 kết nối CE-B1 (R8) và CE-B2 (R9)

Thực hiện mô phỏng

3.3.4.1. Công cụ thực hiện

Bài mô phỏng được thực hiện giả lập trên chương trình GNS3 (Graphical

Network Simulator). GNS3 Là chương trình mã nguồn mở miễn phí tạo ra các sơ đồ

mạng (gồm các thiết bị Router, Ethernet Switch, Frame Relay Switch, PIX Firewall, PC,

cloud...) trên môi trường đồ họa. Đặc biệt, GNS3 được sử dựng trên nền chương trình

Dynamips Router Simuỉator cho phép các thiết bị chạy hệ điều hành IOS thật của Cisco.

Lợi ích của GNS3 là chạy hệ điều hành IOS thật nên tập lệnh đầy đủ và đồ họa dễ sử

dụng và sát với thục tế.

3.3.4.2. Các bước thực hiện

 Bước 1: Khai báo địa chỉ IP và kích hoạt các giao diện trên các bộ định tuyến

Sau khi khai báo để kiểm tra địa chỉ IP và trạng thái các giao diện của các bộ định

tuyến, sử dụng câu lệnh: show ip interface brief



Hình 3.5. Ví dụ kiểm tra IP và kích hoạt các giao diện trên PE1

 Bước 2: Xây dựng miền OSPF trong MPLS domain.

Cấu hình giao thức định tuyến OSPF cho các bộ định tuyến trong miền MPLS,

sau khi mạng được hội tụ, bảng định tuyến được thể hiện như hình 3.6 sau:



Đậu Văn Thắng – D13VT6



70



Đồ án tốt nghiệp đại học



Hình 3.6. Ví dụ kiểm tra bảng định tuyến OSPF trên PE1

 Bước 3 : Xây dựng miền MPLS

Kích hoạt tính năng cef của bộ định tuyến trong miền MPLS, bao gồm PE1, PE2,

PE3, P. Trong các phiên bản IOS mới, tính năng cef đã được mặc định kích hoạt.

PE1(config)#ip cef

PE2(config)#ip cef

PE3(config)#ip cef

P(config)#ip cef

Chọn giao thức phân bổ nhãn LDP/TDP trong miền MPLS. Trong các phiên bản

IOS cũ giao thức TDP là mặc định, trong các phiên bản IOS mới giao thức LDP là mặc

định.

PE1(config)#mpls label protocol ldp

PE2(config)#mpls label protocol ldp

PE3(config)#mpls label protocol ldp

P(config)#mpls label protocol ldp

Xây dựng miền MPLS (kích hoạt MPLS trên các giao diện)

Trên PE1 :

PE1(config)#interface e 0/1

PE1(config-if)# mpls ip

Trên PE2 :

PE2(config)#interface e 0/2

PE2(config-if)# mpls ip



Đậu Văn Thắng – D13VT6



71



Đồ án tốt nghiệp đại học

Trên PE3 :

PE3(config)#interface e0/3

PE3(config-if)# mpls ip

Trên P :

P(config)#interface range e0/1-3

P(config-if)# mpls ip

 Bước 4: Kiểm tra thơng tin cấu hình và bảng chuyển tiếp nhãn của các bộ

định tuyến thuộc miền MPLS.

Để kiểm tra thơng tin cấu hình và bảng chuyển tiếp nhãn, ta sử dụng các câu lệnh

như sau:

RouterX#show mpls interfaces (detail)

RouterX#show mpls ldp neighbor (detail)

RouterX#show mpls forwarding-table (detail)



Hình 3.7. Kiểm tra thơng tin cấu hình MPLS và bảng chuyển tiếp nhãn PE1

 Bước 5: Cấu hình các kết nối quan hệ hàng xóm ngang hàng BGP trong miền

MPLS

 Trên PE1 :



Đậu Văn Thắng – D13VT6



72



Đồ án tốt nghiệp đại học

PE1(config)#router bgp 123

PE1(config-router)# bgp log-neighbor-changes

PE1(config-router)# neighbor 2.2.2.2 remote-as 123

PE1(config-router)# neighbor 2.2.2.2 update-source Loopback1

PE1(config-router)# neighbor 3.3.3.3 remote-as 123

PE1(config-router)# neighbor 3.3.3.3 update-source Loopback1

PE1(config-router)# address-family ipv4

PE1(config-router-af)# neighbor 2.2.2.2 activate

PE1(config-router-af)# neighbor 3.3.3.3 activate

 Trên PE2 :

PE2(config)#router bgp 123

PE2(config-router)# bgp log-neighbor-changes

PE2(config-router)# neighbor 1.1.1.1 remote-as 123

PE2(config-router)# neighbor 1.1.1.1 update-source Loopback1

PE2(config-router)# address-family ipv4

PE2(config-router-af)# neighbor 1.1.1.1 activate

 Trên PE3 :

PE3(config)#router bgp 123

PE3(config-router)# bgp log-neighbor-changes

PE3(config-router)# neighbor 1.1.1.1 remote-as 123

PE3(config-router)# neighbor 1.1.1.1 update-source Loopback1

PE3(config-router)# address-family ipv4

PE3(config-router-af)# neighbor 1.1.1.1 activate

Sau khi bộ định tuyến thiết lập quan hệ hàng xóm, để kiểm tra trạng thái thiết lập

quan hệ của các bộ định tuyến sử dụng câu lệnh:

RouterX#show ip bgp all summary



Đậu Văn Thắng – D13VT6



73



Đồ án tốt nghiệp đại học



Hình 3.8. Ví dụ kiểm tra trạng thái neighbor BGP của PE1

 Bước 6: Xây dựng các VPN-L3 sử dụng giao thức MP-BGP trên miền MPLS

đã xây dựng được trước đó.

Đầu tiên, ta cần tạo profile VRF ( với giá trị RD và RT tương ứng cho khách

hàng ) và gán vào interface tương ứng.

VRF A . Thông số: RD (100:100), RT (100:100)

PE1(config)#ip vrf A

PE1(config-vrf)# rd 100:100

PE1(config-vrf)#route-target export 100:100

PE1(config-vrf)#route-target import 100:100

PE1(config)#interface e0/0

PE1(config-inf)#ip vrf forwarding A

PE1(config-inf)#ip address 192.168.15.1 255.255.255.0

VRF B. Thông số: RD (200:200), RT (200:200)

PE1(config)# ip vrf B

PE1(config-vrf)#rd 200:200

PE1(config-vrf)#route-target export 200:200

PE1(config-vrf)#route-target import 200:200

PE1(config)#interface e1/0

PE1(config-inf)#ip vrf forwarding B

PE1(config-inf)#ip address 192.168.18.1 255.255.255.0

Lưu ý : Sau khi gán VRF vào interface sẽ auto remove địa chỉ IP đã được đặt trước

đó. Ta cần cấu hình lại IP cho interface.



Đậu Văn Thắng – D13VT6



74



Tài liệu bạn tìm kiếm đã sẵn sàng tải về

CHƯƠNG 3: ỨNG DỤNG CÔNG NGHỆ IP MULTICAST TRONG MPLS VPN (MPVN)

Tải bản đầy đủ ngay(0 tr)

×